There was no "Disconnected" sign. Yet almost none of my...

« Back

75 days, 6 hours, 54 minutes ago
Profile Image
mcnimble
There was no "Disconnected" sign. Yet almost none of my...Write Reply
There was no "Disconnected" sign. Yet almost none of my commands of this morning came through.

And that's the scary part. almost none. Two freighters moved. My war fleet didn't. Missions reset, etc. Looking at history, as if I didn't give any command. Makes no sense.

Cost me only one Resolute, but this is not good for my trust levels...
75 days, 4 hours, 46 minutes ago
Profile Image
nebulon
RE: There was no "Disconnected" sign. Yet almost none of my...Write Reply
Mine went OK in the same game, I suspect. Are you using the new or old client?
75 days, 2 hours, 55 minutes ago
View smn's profile
smn
RE: There was no "Disconnected" sign. Yet almost none of my...Write Reply
Was there anything unusual from where you played from? Specific equipment or network? I know of a case where orders were consistently lost by a player in a very specific network setting.
75 days, 0 hours, 10 minutes ago
View j-zan's profile
j-zan
RE: There was no "Disconnected" sign. Yet almost none of my...Write Reply
That stinks McNimble. I was shocked that I was able to intercept that Ressie.


I just want to add - it looks to me like one of your ships reverted from a custom name back to a default? (S.494). Not sure if that's more "lost orders" or something you intended.
74 days, 19 hours, 23 minutes ago
Profile Image
glynsalternate
RE: There was no "Disconnected" sign. Yet almost none of my...Write Reply
For the Old Client doesn't the 'Disconnected' sign just pop-down and then disappear after a couple seconds? You could have just missed it. Why they changed it to a temporary display I'll never understand.
74 days, 17 hours, 48 minutes ago
Profile Image
martinr
RE: There was no "Disconnected" sign. Yet almost none of my...Write Reply
There was a time recently when the site went down for a considerable time when I was doing my turns. During that time the disconnect was on all the time. This was the old client.
74 days, 16 hours, 56 minutes ago
Profile Image
mcnimble
RE: There was no "Disconnected" sign. Yet almost none of my...Write Reply
Spotty wifi connection. Sometimes quick, sometimes ultra-slow. My network changes often, sailing from harbour to harbour.

Wondering what happens when you go to historical turn, when you have a ship pane open. Those commands must be sent to the server, but the client looses sight of that turn. Assume I had the historical turns loaded already, so client switches quickly. The Disconnected state triggers, as the commands do not get through. But is it shown?

Then wondering what happens when I return to Now and the connection status is Disconnected still, will it be shown?

But totally surprised that NOTHING after that would have come through to the server The wifi was not that bad. and End Turn came through, quite alright. (The LDSFs were early commands of the day.) Really makes me think no attempt to submit commands was made anymore, but from what I have seen of the code, attempts are always made when you close a ship/planet/base pane.

Generally, don't recall Disconnect disappearing, except when connection is reestablished. Both clients (that code is still the same, I would expect).

And yes, the Resolute was intended to Super Spy and move a few LY in a sorta-random direction ;) Will check S494 now.
74 days, 16 hours, 51 minutes ago
Profile Image
mcnimble
RE: There was no "Disconnected" sign. Yet almost none of my...Write Reply
mm, many ships renamed.
Going to blame an experimental plugin that someone gave me. About renaming ships, and the default is ship type names. Which I didn't touch because Dogfights.

Hadn't noticed, yet, though. Thx.
74 days, 13 hours, 56 minutes ago
Profile Image
glynsalternate
RE: There was no "Disconnected" sign. Yet almost none of my...Write Reply
Just ran some tests in Chrome using Old Client;

"Disconnected" sign doesn't show up at all while on the Starmap... requires going to the Dashboard for it to appear... but then it stays displayed until you are reconnected.

This is definitely not how it worked when I last complained to the Admins about it only temporarily showing up... so I'm guessing they fixed it to be permanent, but now doesn't show up until you view the Dashboard.

Also... the Old Client now apparently can freeze up while disconnected.

So another couple downside of the Old Client to keep in mind.
74 days, 5 hours, 35 minutes ago
Profile Image
mcnimble
RE: There was no "Disconnected" sign. Yet almost none of my...Write Reply
Another theory. Wifi time outs are very long.

So if I give a dozen commands and then look at the history before the timeout happens...
(I looked at the history a lot)

(I'll have to check these theories with the code, but not today)
73 days, 17 hours, 16 minutes ago
Profile Image
martinr
RE: There was no "Disconnected" sign. Yet almost none of my...Write Reply
I just had a disconnection on old UI. Waited a few minutes. Did not change. Tried to log onto new site. Did not log on. Tried old site did not show forums (old data still logged).

Went to another web site and it worked. Forgot about the site then went back 30 mins later and the disconnect was still up for the map and ship I was on.

Tried the new site and it worked.

Clicked on advance ship and the disconnect vanished on old UI. So if you get a disconnect on at least the old UI keep advancing ships / planets etc to see if still disconnected.
71 days, 17 hours, 44 minutes ago
Profile Image
mcnimble
RE: There was no "Disconnected" sign. Yet almost none of my...Write Reply
OK, figured it out.
1) My mistake, sorta, fiddling so much with ObjectSelection
2) but jeez, admins, when you have a method in the client to compute map coordinates from screen coordinates, can you return LEGAL map coordinates?
3) and if not, will you NOTIFY THE CLIENT that the ship commands were NOT applied on the server? Not just the movement commands, but none of the commands? C# has nifty exception mechanisms for precisely this kind of stuff.

So all ships that were flying into deep space did not any get command executed, which is why e.g. the Resolute (a) did not move, and also (b) did not cloak.

Going to redo my Dogfights turn, now. At least not so many ships as Klamuth...